<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML+RDFa 1.0//EN"
  "http://www.w3.org/MarkUp/DTD/xhtml-rdfa-1.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="alternate" type="application/rss+xml" title="Jack Baskin School of Engineering Events (RSS)" href="https://www.soe.ucsc.edu/events/feed/rss" />
<link rel="alternate" type="application/rss+xml" title="Jack Baskin School of Engineering Events (iCal)" href="https://www.soe.ucsc.edu/events/feed/ical" />
<link rel="alternate" type="application/rss+xml" title="Jack Baskin School of Engineering News" href="https://www.soe.ucsc.edu/news/feed/rss" />
<link rel="canonical" href="/events/tim-2030-future-work-and-education-and-designing-architectures-and-loss-functions-instead" />
<link rel="shortlink" href="/node/5509" />
<link rel="prev" href="/events/ece-seminar-oz-vision-new-principle-color-display" />
<link rel="next" href="/events/am-seminar-applied-math-harvesting-data-and-model-revolution" />
<meta name="author" content="adsweins" />
<meta name="last-modified" content="Sun, 18 Apr 2021 18:23:24 -0700" />
<meta property="og:site_name" content="Jack Baskin School of Engineering" />
<meta property="og:url" content="https://www.soe.ucsc.edu/events/tim-2030-future-work-and-education-and-designing-architectures-and-loss-functions-instead" />
<meta property="og:type" content="article" />
<meta property="og:title" content="TIM 2030: the future of work and education and Designing architectures and loss functions (instead of doing calculus) using the PyTorch machine/deep learning framework" />
<meta property="og:image" content="https://www.soe.ucsc.edu/sites/all/themes/bsoev3/baskin-logo-normal.svg" />
<link rel="shortcut icon" href="https://www.soe.ucsc.edu/sites/all/themes/bsoev3/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
  <title>TIM 2030: the future of work and education and Designing architectures and loss functions (instead of doing calculus) using the PyTorch machine/deep learning framework | Jack Baskin School of Engineering</title>
  <style type="text/css" media="all">
@import url("https://www.soe.ucsc.edu/modules/system/system.base.css?qofmfe");
@import url("https://www.soe.ucsc.edu/modules/system/system.menus.css?qofmfe");
@import url("https://www.soe.ucsc.edu/modules/system/system.messages.css?qofmfe");
@import url("https://www.soe.ucsc.edu/modules/system/system.theme.css?qofmfe");
</style>
<style type="text/css" media="all">
@import url("https://www.soe.ucsc.edu/sites/all/modules/date/date_api/date.css?qofmfe");
@import url("https://www.soe.ucsc.edu/modules/field/theme/field.css?qofmfe");
@import url("https://www.soe.ucsc.edu/modules/node/node.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/soe_events/soe_events.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/soe_image_caption/soe_image_caption.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/soe_news/soe_news.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/soe_slideshow/soe_slideshow.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/ucsc_macros/ucsc_macros.css?qofmfe");
@import url("https://www.soe.ucsc.edu/modules/user/user.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/views/css/views.css?qofmfe");
</style>
<style type="text/css" media="all">
@import url("https://www.soe.ucsc.edu/sites/all/modules/colorbox/styles/default/colorbox_style.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/ctools/css/ctools.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/soe_banners/soe_banners.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/soe_macros/soe_macros.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/flippy/flippy.css?qofmfe");
@import url("https://www.soe.ucsc.edu/sites/all/modules/addtoany/addtoany.css?qofmfe");
</style>
<style type="text/css" media="all">
@import url("https://www.soe.ucsc.edu/sites/all/themes/bsoev3/bsoev3.css?qofmfe");
</style>
<style type="text/css" media="all">
@import url("https://www.soe.ucsc.edu/sites/default/update.css?qofmfe");
</style>
  <script type="text/javascript" src="https://www.soe.ucsc.edu/misc/jquery.js?v=1.4.4"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/misc/jquery-extend-3.4.0.js?v=1.4.4"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/misc/jquery-html-prefilter-3.5.0-backport.js?v=1.4.4"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/misc/jquery.once.js?v=1.2"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/misc/drupal.js?qofmfe"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/sites/all/modules/soe_events/soe_events.js?qofmfe"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/sites/all/modules/soe_slideshow/soe_slideshow.js?qofmfe"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/sites/default/modules/soe_tr/soe_tr.js?qofmfe"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/sites/all/libraries/colorbox/jquery.colorbox-min.js?qofmfe"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/sites/all/modules/colorbox/js/colorbox.js?qofmfe"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/sites/all/modules/colorbox/styles/default/colorbox_style.js?qofmfe"></script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/sites/all/modules/soe_macros/base64.js?qofmfe"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.a2a_config=window.a2a_config||{};window.da2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='https://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);da2a.script_load=function(){};},script_onready:function(){da2a.script_ready=true;if(da2a.html_done)da2a.init();},init:function(){for(var i=0,el,target,targets=da2a.targets,length=targets.length;i<length;i++){el=document.getElementById('da2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}da2a.done=true;}da2a.targets=[];}};(function ($){Drupal.behaviors.addToAny = {attach: function (context, settings) {if (context !== document && window.da2a) {if(da2a.script_ready)a2a.init_all();da2a.script_load();}}}})(jQuery);a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:da2a.script_onready});a2a_config.overlays=a2a_config.overlays||[];a2a_config.templates=a2a_config.templates||{};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.soe.ucsc.edu/sites/all/themes/bsoev3/bsoev3.js?qofmfe"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"bsoev3","theme_token":"kmQSfexRvG1rgP55gDRnjvoUDsN2xxQPbkDv0lkgy28","js":{"0":1,"misc\/jquery.js":1,"misc\/jquery-extend-3.4.0.js":1,"misc\/jquery-html-prefilter-3.5.0-backport.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/soe_events\/soe_events.js":1,"sites\/all\/modules\/soe_slideshow\/soe_slideshow.js":1,"sites\/default\/modules\/soe_tr\/soe_tr.js":1,"sites\/all\/libraries\/colorbox\/jquery.colorbox-min.js":1,"sites\/all\/modules\/colorbox\/js\/colorbox.js":1,"sites\/all\/modules\/colorbox\/styles\/default\/colorbox_style.js":1,"sites\/all\/modules\/soe_macros\/base64.js":1,"1":1,"sites\/all\/themes\/bsoev3\/bsoev3.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"sites\/all\/modules\/soe_events\/soe_events.css":1,"sites\/all\/modules\/soe_image_caption\/soe_image_caption.css":1,"sites\/all\/modules\/soe_news\/soe_news.css":1,"sites\/all\/modules\/soe_slideshow\/soe_slideshow.css":1,"sites\/all\/modules\/ucsc_macros\/ucsc_macros.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/colorbox\/styles\/default\/colorbox_style.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/soe_banners\/soe_banners.css":1,"sites\/all\/modules\/soe_macros\/soe_macros.css":1,"sites\/all\/modules\/flippy\/flippy.css":1,"sites\/all\/modules\/addtoany\/addtoany.css":1,"sites\/all\/themes\/bsoev3\/bsoev3.css":1,"sites\/default\/update.css":1}},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px","specificPagesDefaultValue":"admin*\nimagebrowser*\nimg_assist*\nimce*\nnode\/add\/*\nnode\/*\/edit\nprint\/*\nprintpdf\/*\nsystem\/ajax\nsystem\/ajax\/*"}});
//--><!]]>
</script>
</head>
<body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-5509 node-type-soe-events-event" >
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    

<!-- begin page -->

<div style="padding: 12px;font-size: 20px;background-color: #fff3cd;color: #856404;">Stay Informed:<br><a href="https://organization.soe.ucsc.edu/covid-19-information-and-resources" style="color: #006aad;font-weight: 600;text-decoration: underline;">Baskin Engineering COVID-19 Information and Resources</a><br><a href="https://recovery.ucsc.edu"  style="color: #006aad;font-weight: 600;text-decoration: underline;">Campus Roadmap to Recovery</a><br>Zoom Links: <a href="https://its.ucsc.edu/zoom/index.html" style="color: #006aad;font-weight: 600;text-decoration: underline;">Zoom Help</a> | <a href="https://docs.google.com/document/d/1cHSbDr6boxZCdDyP2rmrO12xlH-i1v0E0ckJDL_kTtc" style="color: #006aad;font-weight: 600;text-decoration: underline;">Teaching with Zoom</a> | <a href="https://docs.google.com/document/d/1crAXuA4bDI61l0v6u4VcdJD2FKRx_xhICK1VPhOYRXE" style="color: #006aad;font-weight: 600;text-decoration: underline;">Zoom Quick Guide</a></div>
<div id="site-wrapper">
<div id="header">
<div id="header-logo">
<a href="/"><img src="https://www.soe.ucsc.edu/sites/all/themes/bsoev3/baskin-logo-normal.svg"></a>
</div>
<div id="header-name-and-slogan">
<div id="header-name">
<a href="/">Jack Baskin School of Engineering</a>
</div>
<div id="header-slogan">
Technology for a Changing World
</div>
</div>
</div>
<div id="middle-wrapper">
<div id="navigation-button-wrapper">
<div id="navigation-button">
Navigation
</div>
</div>
<div id="navigation-wrapper">
  <div class="region region-menu">
    <div id="block-system-main-menu" class="block block-system block-menu">


<div class="content">
<ul class="menu"><li class="first leaf"><a href="/home">Home</a></li>
<li class="collapsed"><a href="/about" title="About Us">About Us</a></li>
<li class="collapsed"><a href="/academics" title="Academics">Academics</a></li>
<li class="collapsed"><a href="/departments" title="Departments">Departments</a></li>
<li class="leaf"><a href="/degree-programs" title="Undergraduate and graduate degrees offered">Degree Programs</a></li>
<li class="collapsed"><a href="/people" title="People">People</a></li>
<li class="collapsed"><a href="/research" title="Research">Research</a></li>
<li class="last leaf"><a href="/quick-links" title="Quick Links">Quick Links</a></li>
</ul>
</div>
</div>
  </div>

  <div class="region region-sidebar-first">
    <div id="block-soe-google-cse-soe-google-cse" class="block block-soe-google-cse">


<div class="content">
<form action="//www.google.com/cse" id="soe-google-cse-box">
<div>
<input type="hidden" name="cx" value="006624592689429442921:cwwqopww-z8" />
<input type="hidden" name="ie" value="UTF-8" />
<input type="text" name="q" size="31" id="soe-google-cse-input" />
<input type="submit" name="sa" value="Search" id="soe-google-cse-submit" />
</div>
</form>

</div>
</div>
  </div>


</div>
<div id="body-wrapper">
<div class="breadcrumb"><a href="/events">Events</a></div><h1>TIM 2030: the future of work and education and Designing architectures and loss functions (instead of doing calculus) using the PyTorch machine/deep learning framework</h1>
<div id="content">
<div id="content-tabs">
</div>
  <div class="region region-content">
    <div id="block-system-main" class="block block-system">


<div class="content">
<div id="node-5509" class="node node-soe-events-event clearfix">

  
      
  
  <div class="content">
    <ul class="flippy">
          
    <li class="prev">
              <a href="/events/ece-seminar-oz-vision-new-principle-color-display" title="‹ Previous">‹ Previous</a>          </li>
          
    <li class="next">
              <a href="/events/am-seminar-applied-math-harvesting-data-and-model-revolution" title="Next ›">Next ›</a>          </li>
  </ul>

<div class="field field-name-soe-event-speaker-name field-type-text field-label-inline clearfix"><div class="field-label">Speaker Name:&nbsp;</div><div class="field-items"><div class="field-item even">Dr. James Shanahan</div></div></div><div class="field field-name-soe-event-speaker-title field-type-text field-label-inline clearfix"><div class="field-label">Speaker Title:&nbsp;</div><div class="field-items"><div class="field-item even">Venture Partner, R3i Capital, and Lecturer</div></div></div><div class="field field-name-soe-event-speaker-organization field-type-text field-label-inline clearfix"><div class="field-label">Speaker Organization:&nbsp;</div><div class="field-items"><div class="field-item even">University of California Berkeley (UCB)</div></div></div><div class="field field-name-soe-event-start-time field-type-datestamp field-label-inline clearfix"><div class="field-label">Start Time:&nbsp;</div><div class="field-items"><div class="field-item even"><span class="date-display-single">Monday, April 19, 2021 - 1:00pm</span></div></div></div><div class="field field-name-soe-event-end-time field-type-datestamp field-label-inline clearfix"><div class="field-label">End Time:&nbsp;</div><div class="field-items"><div class="field-item even"><span class="date-display-single">Monday, April 19, 2021 - 2:15pm</span></div></div></div><div class="field field-name-soe-event-location field-type-text field-label-inline clearfix"><div class="field-label">Location:&nbsp;</div><div class="field-items"><div class="field-item even">Via Zoom Link</div></div></div><div class="field field-name-soe-event-organizer field-type-text field-label-inline clearfix"><div class="field-label">Organizer:&nbsp;</div><div class="field-items"><div class="field-item even">David Lee</div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"><h2 class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;">Abstract:</h2>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;"><strong><em><span style="font-family: Georgia, serif; color: #002060;"><u></u>&nbsp;<u></u></span></em></strong></p>
<p>Job Talk:</p>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;"><span style="color: #444444; font-family: 'Open Sans', sans-serif; font-size: 1em;">AI combined with the covid-19 pandemic has led to increased automation in several sectors. Over the next decade, 10-30% of the global workforce (250-800 million people) will be displaced by automation, while 10% of the workforce is likely to be new occupations. For workers of the future, the ability to adapt their skills to the changing needs of the workplace will be critical.&nbsp; A key stakeholder on this front are schools who serve as the pipeline for tomorrow’s workers.&nbsp; Education needs to prepare students for a future that is not just already highly automated but increasingly so. Automation, machine learning and artificial intelligence are only getting better and smarter, so designing curricula that challenges students’ ingenuity and problem-solving capabilities in the classroom is vital. But education will only be effective in preparing students if we have a clear understanding of where industries, and the economy, are heading. Without hearing from employers, faculty might design coursework in a way that is not preparing our students for the future they will face beyond graduation. While collaboration between academia and employers currently takes place, it needs to happen more as the workplace evolves at an accelerating rate due to automation and more recently the pandemic.</span></p>
<p>&nbsp;&nbsp;<br />The TIM program at UCSC is uniquely positioned to offer undergraduate students (and in the future, possibly, graduate students) a unique blend of engineering and business training that can be highly influenced by Silicon Valley needs. Another key to success is to partner with Silicon Valley companies and organizations that will &nbsp;enable students to have residencies/coops, thereby being able to apply skills that they have studied in a classroom to the real world, inside some of the world’s most exciting tech organizations.&nbsp; In this part of the talk, I will present some thoughts on how to be successful in this brave new highly automated world for individuals, commercial organizations, for educational institutions, and for UCSC in particular. I will also outline a proposal for 4+1 TIM degrees program.</p>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;">&nbsp;Class room lecture:</p>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;">&nbsp;</p>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;"><u></u>In earlier lectures (in this course) we have seen that gradient descent&nbsp;is a first-order iterative optimization algorithm for finding a local minimum of a differentiable function.&nbsp;In addition, we saw that gradient descent is a fundamental building block for most machine learning algorithms.&nbsp;</p>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;">&nbsp;</p>
<p>This lecture introduces the PyTorch machine learning framework and &nbsp;shows how&nbsp;to avoid doing calculus explicitly and how to simplify gradient descent code when implementing a variety of machine/deep learning algorithms. This is accomplished via tensor programming, computational graphs, and auto-differentiation, all of which are core components of PyTorch. This simplification allows the construction of, say, an image classifier in a few lines of code where your focus, as a modeler, shifts to designing model architectures and loss functions. These core concepts will be presented here and grounded in some exciting examples from image classification and object detection.&nbsp;</p>
<h2 class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;"><span style="font-family: Georgia, serif; color: #002060;">Bio:</span></h2>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif;">&nbsp;</p>
<p>Dr. James G. Shanahan has spent the past 30 years developing and researching cutting-edge artificial intelligence systems, splitting his time between industry and academia. He is currently a venture partner at R3i Ventures and teaches large scale machine learning and deep learning at UC Berkeley as part of the MIDS (Masters in Data Science) faculty. For the academic year 2019-2020, Jimi held the position of Rowe Professor of Data Science at Bryant University, Rhode Island. He has (co) founded several companies that leverage AI/machine learning/deep learning/computer vision in verticals such as digital advertising, web search, local search, and smart cameras. Previously he has held appointments at AT&amp;T (Executive Director of Research), NativeX (SVP of data science), Xerox Research (staff research scientist), and Mitsubishi. He is on the board of Anvia, and he also advises several high-tech startups including Aylien, ChartBoost, DigitalBank, LucidWorks, and others. Dr. Shanahan received his PhD in engineering mathematics and computer vision from the University of Bristol, U. K. in 1998. His research interests include: deep learning for computer vision and NLP, effective teaching and learning, digital advertising, and personalization.</p>
<p>&nbsp;<u></u><span lang="EN">As a gentle reminder, please respect the privacy of faculty recruitment by not sharing the candidate status of our guests with others outside of our organization.</span></p>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif; line-height: 14.949999809265137px;"><span lang="EN">&nbsp;Zoom Link: &nbsp;&nbsp;</span></p>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif; line-height: 14.949999809265137px;">&nbsp;</p>
<p class="MsoNormal" style="margin-bottom: 0px; caret-color: #222222; color: #222222; font-family: Arial, Helvetica, sans-serif; line-height: 14.949999809265137px;"><a style="font-family: 'Open Sans', sans-serif; font-size: 1em;" href="https://www.google.com/url?q=https://ucsc.zoom.us/j/91596537165?pwd%3DWGZkQyt1STJXc3VEcHhFa1BIaC95QT09&amp;sa=D&amp;source=calendar&amp;ust=1619227092628000&amp;usg=AOvVaw0q_EK9H7YLI5y2c3qUpims">https://ucsc.zoom.us/j/91596537165?pwd=WGZkQyt1STJXc3VEcHhFa1BIaC95QT09</a></p></div></div></div><div class="field field-name-field-event-type field-type-list-text field-label-above"><div class="field-label">Event Type:&nbsp;</div><div class="field-items"><div class="field-item even">Event</div></div></div><span class="a2a_kit a2a_target addtoany_list" id="da2a_1">
      <a class="a2a_button_facebook"></a>
<a class="a2a_button_twitter"></a>
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fwww.soe.ucsc.edu%2Fevents%2Ftim-2030-future-work-and-education-and-designing-architectures-and-loss-functions-instead&amp;title=TIM%202030%3A%20the%20future%20of%20work%20and%20education%20and%20Designing%20architectures%20and%20loss%20functions%20%28instead%20of%20doing%20calculus%29%20using%20the%20PyTorch%20machine%2Fdeep%20learning%20framework"></a>
      
    </span>
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
if(window.da2a)da2a.script_load();
//--><!]]>
</script>  </div>

  
  
</div>

</div>
</div>
  </div>
</div>
</div>
</div>
</div>
<div id="footer-wrapper">
<div id="footer">
<div id="footer-left">
<a href="http://www.ucsc.edu/">UCSC</a></div>
<div id="footer-center">
<p id="footer-contact">This site is maintained by: <a href="mailto:webmaster@soe.ucsc.edu">webmaster@soe.ucsc.edu</a></p><p id="footer-address">UC Santa Cruz, 1156 High Street, Santa Cruz, CA 95064</a></p><p id="footer-copyright">Copyright &copy; 2021 The Regents of the University of California. All rights reserved.</p></div>
<div id="footer-right">
  <div class="region region-footer">
    <div id="block-block-21" class="block block-block">


<div class="content">
<p align="right"><a href="https://twitter.com/UCSC_BSOE"><img src="/sites/default/files/twitter.png" alt="Follow Us On Twitter" title="Follow Us On Twitter"></a>&nbsp;<a href="https://www.facebook.com/BaskinSchoolofEngineering"><img src="/sites/default/files/facebook.png" alt="Follow Us On Facebook" title="Follow Us On Facebook"></a></p>
</div>
</div>
<div id="block-soe-log-in-0" class="block block-soe-log-in">


<div class="content">
<a href="/user/login?destination=node/5509" rel="nofollow">Log In</a>
</div>
</div>
<div id="block-block-19" class="block block-block">


<div class="content">
<script type="text/javascript">// <![CDATA[
var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-23699662-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
// ]]></script>
</div>
</div>
  </div>
</div>
</div>
</div>


<!-- end page -->

  <script type="text/javascript">
<!--//--><![CDATA[//><!--
da2a.targets=[
{title:"TIM 2030: the future of work and education and Designing architectures and loss functions (instead of doing calculus) using the PyTorch machine\/deep learning framework",url:"https:\/\/www.soe.ucsc.edu\/events\/tim-2030-future-work-and-education-and-designing-architectures-and-loss-functions-instead"}];
da2a.html_done=true;if(da2a.script_ready&&!da2a.done)da2a.init();da2a.script_load();
//--><!]]>
</script>
</body>
</html>
